How to enable SSH remote access on VMware ESXi 5

Question: I installed VMware ESXi 5.5 on a bare-metal host. I would like to remote access the ESXi host via SSH, but an SSH server does not seem to be running on it as I cannot SSH to the ESXi host. How can I enable SSH remote access on an ESXi host?

When you install VMware ESXi, SSH remote access is turned off by default. If you want to access an ESXi host with SSH, you need to enable it first. To do so, you first need to log in to the ESXi host from VMware vSphere client. Only a Windows version of VMware vSphere client is available.

Assuming that you logged in to your ESXi host from vShere client installed somewhere, you can follow this instruction to activate SSH service. This instruction is applicable on VMware ESXi 5.1 and 5.5

On vShere client, first select your ESXi host on the left panel to make it highlighted. Then click on "Configuration" tab in the right. Finally, click on "Security Profile" under "Software" section in the left side of the right panel.

In the next window, you will see a list of services, and their daemon status. Choose "SSH" and click on "Options" button.

This will pop up an SSH configuration window shown below. Click on "Start" button to start SSH daemon now.

Verify that SSH daemon is running. At this point SSH remote access should be available. To enable SSH service permanently (i.e., autostart SSH upon boot), change SSH startup policy by clicking on "Start and stop with host" bullet. Click on "OK" button to finalize.

Now SSH remote access will automatically be started upon ESXi boot.

Download this article as ad-free PDF (made possible by your kind donation): 
Download PDF

Subscribe to Ask Xmodulo

Do you want to receive Linux related questions & answers published at Ask Xmodulo? Enter your email address below, and we will deliver our Linux Q&A straight to your email box, for free. Delivery powered by Google Feedburner.

Support Xmodulo

Did you find this tutorial helpful? Then please be generous and support Xmodulo!

Leave a comment

Your email address will not be published. Required fields are marked *